bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1737: [Vincent Lefevre] The End key doesn't work in xterm-vt220.


From: Dan Nicolaescu
Subject: bug#1737: [Vincent Lefevre] The End key doesn't work in xterm-vt220.
Date: Tue, 30 Dec 2008 02:03:08 -0800 (PST)

Sven Joachim <address@hidden> writes:

  > It seems that Emacs sees the <end> key as <select> in vt220 terminals.
  > Run "xterm -ti vt220 -kt vt220", in that xterm "emacs -Q -nw" and press
  > C-h k <end>.  You get the message: "<select> is undefined".

Did you miss one step: set TERM to xterm-vt220 ? 
After doing that emacs -Q -nw works just fine for me (with emacs from
CVS HEAD)

  > From: Vincent Lefevre <address@hidden>
  > Subject: Bug#173983: emacs21: The End key doesn't work in xterm-vt220.
  > To: address@hidden
  > Date: Sun, 22 Dec 2002 20:28:32 +0100
  > Reply-To: Vincent Lefevre <address@hidden>, address@hidden
  > Resent-From: Vincent Lefevre <address@hidden>
  > 
  > Package: emacs21
  > Version: 21.2-1
  > Severity: normal
  > 
  > When emacs is run in an xterm with the VT220 keyboard and the
  > xterm-vt220 terminfo, the End key is incorrectly regarded as
  > <select> instead of <end>, according to describe-key. I tried
  > with emacs -q -nw.
  > 
  > For the End key, infocomp says:
  > 
  >   kend=\E[4~
  > 
  > and there's nothing about kslt.
  > 
  > The other applications, like Mutt, Tin and Less, recognize the
  > End key correctly.
  > 
  > -- System Information
  > Debian Release: testing/unstable
  > Kernel Version: Linux ay 2.4.18-newpmac #1 Thu Mar 14 22:44:49 EST 2002 ppc 
 7410, altivec supported GNU/Linux
  > 
  > Versions of the packages emacs21 depends on:
  > ii  dpkg           1.10.9         Package maintenance system for Debian
  > ii  emacsen-common 1.4.15         Common facilities for all emacsen.
  > ii  libc6          2.2.5-14.3     GNU C Library: Shared libraries and 
Timezone
  > ii  libjpeg62      6b-6           The Independent JPEG Group's JPEG runtime 
li
  > ii  liblockfile1   1.03           NFS-safe locking library, includes 
dotlockfi
  > ii  libncurses5    5.2.20020112a- Shared libraries for terminal handling
  > ii  libpng2        1.0.12-3.woody PNG library - runtime
  > ii  libtiff3g      3.5.5-6        Tag Image File Format library
  > ii  xaw3dg         1.5-14         Xaw3d widget set
  > ii  xlibs          4.2.1-3        X Window System client libraries
  > ii  zlib1g         1.1.4-6        compression library - runtime
  > 
  > 
  > 
  > ----------






reply via email to

[Prev in Thread] Current Thread [Next in Thread]