bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#119: marked as done (modify-frame-parameters in Emacs 23 for fonts)


From: Emacs bug Tracking System
Subject: bug#119: marked as done (modify-frame-parameters in Emacs 23 for fonts)
Date: Thu, 01 Jan 2009 02:20:04 +0000

Your message dated Thu, 01 Jan 2009 10:10:49 +0800
with message-id <address@hidden>
and subject line Re: bug#1562: 23.0.60; modify-frame-parameters in Emacs 23 for 
fonts
has caused the Emacs bug report #1562,
regarding modify-frame-parameters in Emacs 23 for fonts
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
1562: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=1562
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: modify-frame-parameters in Emacs 23 for fonts Date: Sat, 5 Apr 2008 19:17:49 -0700
I'm using this: GNU Emacs 23.0.60.1 (i386-mingw-nt5.1.2600) of 2008-04-04 on
LENNART-69DE564.

(frame-parameter nil 'font) ->
"-*-Lucida Console-normal-r-*-*-14-*-96-96-c-*-iso8859-1"

(modify-frame-parameters
 nil
 (list
  (cons 
   'font
   "-*-Lucida Console-normal-r-*-*-15-*-96-96-c-*-iso8859-1")))

(frame-parameter nil 'font) ->
"-outline-lucida console-normal-roman-normal-mono-15-*-*-*-*-*-fontset-startup"

What's that about? In Emacs 20, 21, and 22, the result is just the font I
specified.

I have code that zooms frames (font size). I change just the point size in the
font spec, using `x-decompose-font-name' and `x-compose-font-name'. I check that
the result is a legitimate font using `x-list-fonts'. If not, I increase or
decrease the increment until I find the font that works with the closest size.

[Yes, I know there are other ways to adjust font size, but I've found that this
method is flexible for users and provides certain benefits.]

My code no longer works without change, because after one call to
`modify-frame-parameters' the font is no longer something recognized by
`x-list-fonts'. I can comment out the part that iterates until it finds a size
that works (recognized by `x-list-fonts'). That works, but I'm still curious
about this. (Is there perhaps a bug in `x-list-fonts' or in
`modify-frame-parameters'?)

I couldn't find anything that helps me understand this in the manuals. I haven't
tried to dig through any code. Can someone light my lantern about this?

I looked in NEWS also, and saw something about a font backend (I didn't follow
the threads here about that). But I couldn't find anything in the Elisp or Emacs
manuals about "backend" or "back?end", except for version-control back ends.

A NEWS entry also says this: "the configure option `--disable-font-backend'
(also available as a run-time option)." But I can't find any such option
(variable) with `backend' or `back-end' in its name (except for
`vc-handled-backends'). I see, in both NEWS and in my frames, a parameter named
`font-backend', but I have no idea what it is. For me, its value is
(font-backend uniscribe gdi), FWIW.

Finding the function `fontp' mentioned in NEWS (but not in the Elisp manual,
alas), I also tried that in place of `x-list-fonts'. But it too does not
indicate that "-outline-lucida
console-normal-roman-normal-mono-15-*-*-*-*-*-fontset-startup" is a legitimate
font.

I see font terms in NEWS that I don't see explained in the manual: font-entity
object, font-spec object, font property value. I also see functions mentioned,
such as `font-font', that my Emacs does not recognize. Are they perhaps only for
X?

This whole area is a murky one, for me. Do others feel that this stuff is
explained well enough - in either the manuals or NEWS? Am I the only dummy about
this? Is this is a hidden subject for some secret club? ;-) If not, how about
some explanation?






--- End Message ---
--- Begin Message --- Subject: Re: bug#1562: 23.0.60; modify-frame-parameters in Emacs 23 for fonts Date: Thu, 01 Jan 2009 10:10:49 +0800 User-agent: Thunderbird 2.0.0.19 (Windows/20081209)
Drew Adams wrote:
After loading, (frame-parameter nil 'font) gives
"-outline-Lucida Console-normal-normal-normal-mono-14-*-*-*-c-*-iso8859-1"

Then do `C-u 5 M-x enlarge-font'. (frame-parameter nil 'font) gives
"-outline-Lucida Console-normal-normal-normal-mono-19-*-*-*-c-*-iso8859-1"
which is correct.

Then do `C-u -5 M-x enlarge-font'. (frame-parameter nil 'font) gives
"-outline-Lucida Console-normal-normal-normal-mono-14-*-*-*-c-*-fontset-auto1"
which is NOT correct.

I have fixed this now, x_new_font in w32term.c had not been updated in line with xterm.c.



--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]