bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2147: marked as done (Crash when adding (font . nil) to `default-fr


From: Emacs bug Tracking System
Subject: bug#2147: marked as done (Crash when adding (font . nil) to `default-frame-alist')
Date: Mon, 02 Feb 2009 15:45:02 +0000

Your message dated Mon, 02 Feb 2009 10:38:00 -0500
with message-id <address@hidden>
and subject line Re: bug#2147: Default font in Emacs
has caused the Emacs bug report #2147,
regarding Crash when adding (font . nil) to `default-frame-alist'
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
2147: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=2147
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Default font in Emacs Date: Mon, 2 Feb 2009 11:06:35 +0800
Package: Emacs
Version: 23.0.90.1
 
Because I prefer the FreeMono font to the default font provided, I
tweak it in my ~/.emacs like this:
 
  (let ((font (cond ((eq window-system 'w32)
                      "-outline-courier 
new-normal-r-normal-normal-16-120-96-96-c-*-fontset-auto2"
                     )
                     ((eq window-system 'x)
                      "FreeMono-13"
                     ))))
    (set-default-font font)
    (add-to-list 'default-frame-alist `(font . ,font)))
 
When I start emacs as a daemon:
 
  $ emacs --daemon
 
The cons cell added to `default-frame-alist' seems to be '(font
. nil). This causes a segfault when running `emacsclient -c':
 
  Program received signal SIGSEGV, Segmentation fault.
  [Switching to Thread 0xb700f700 (LWP 28215)]
  0x0806f438 in estimate_mode_line_height (f=0xa832b38, 
face_id=MODE_LINE_INACTIVE_FACE_ID) at xdisp.c:1646
  1646 int height = FONT_HEIGHT (FRAME_FONT (f));
  (gdb) p FRAME_FONT (f)
  $1 = (struct font *) 0x0
_________________________________________________________________
Drag n’ drop—Get easy photo sharing with Windows Live™ Photos.

http://www.microsoft.com/windows/windowslive/photos.aspx



--- End Message ---
--- Begin Message --- Subject: Re: bug#2147: Default font in Emacs Date: Mon, 02 Feb 2009 10:38:00 -0500 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)
> Because I prefer the FreeMono font to the default font provided, I
> tweak it in my ~/.emacs like this:
 
>   (let ((font (cond ((eq window-system 'w32)
>                       "-outline-courier 
> new-normal-r-normal-normal-16-120-96-96-c-*-fontset-auto2"
>                      )
>                      ((eq window-system 'x)
>                       "FreeMono-13"
>                      ))))
>     (set-default-font font)
>     (add-to-list 'default-frame-alist `(font . ,font)))
 
> When I start emacs as a daemon:
 
>   $ emacs --daemon
 
> The cons cell added to `default-frame-alist' seems to be '(font
> . nil). This causes a segfault when running `emacsclient -c':
 
Emacs just does what you told him to.  The same problem happens if you
start "emacs -nw" and then M-x make-frame-on-display.
In both cases `window-system' is neither `w32' nor `x' so your `font'
variable is set to nil.


        Stefan


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]