bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2165: marked as done (23.0.90; rmail-set-label not functioning)


From: Emacs bug Tracking System
Subject: bug#2165: marked as done (23.0.90; rmail-set-label not functioning)
Date: Tue, 03 Feb 2009 04:15:09 +0000

Your message dated Mon, 02 Feb 2009 23:07:58 -0500
with message-id <address@hidden>
and subject line Re: bug#2165: 23.0.90; rmail-set-label not functioning
has caused the Emacs bug report #2165,
regarding 23.0.90; rmail-set-label not functioning
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
2165: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=2165
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0.90; rmail-set-label not functioning Date: Mon, 2 Feb 2009 16:48:03 +0000
I have the line
(rmail-set-label "exim" t)
in my spam filtering and message classificaton code.  That now fails
saying "exin" is the wrong type
I note that the attributes are strings but in rmail-set-label I get a
failure with
        (regexp (concat ", " (regexp-quote (symbol-name label)) ","))
as a string does not have a symbol-name

Dos thsi mean that unlike previous version a label must be a symbol
and an attribute is a string?

==John ff



In GNU Emacs 23.0.90.1 (i686-pc-linux-gnu, GTK+ Version 2.12.0)
 of 2009-02-02 on cardew
Windowing system distributor `The X.Org Foundation', version 11.0.70200000
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_GB.UTF-8
  value of $XMODIFIERS: @im=local
  locale-coding-system: utf-8-unix
  default-enable-multibyte-characters: t

Major mode: RMAIL

Minor modes in effect:
  auto-image-file-mode: t
  show-paren-mode: t
  display-time-mode: t
  tooltip-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  global-auto-composition-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: (only . t)

Recent input:
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC SPC 
SPC SPC SPC SPC q M-x r e p o r t <tab> <return>

Recent messages:
Result: "X-RMAIL-KEYWORDS"

Result: 16529 (#o40221, #x4091, ?=4091)

Result: nil
 [4 times]
Result: "exim"

Wrong type argument: symbolp, "exim"
Back to top level.

==John ffitch



--- End Message ---
--- Begin Message --- Subject: Re: bug#2165: 23.0.90; rmail-set-label not functioning Date: Mon, 02 Feb 2009 23:07:58 -0500 User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)
This should work now.


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]