bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2264: Failed to build emacs 23.0.90 on Ubuntu 8.10 (x86_64)


From: Yavor Doganov
Subject: bug#2264: Failed to build emacs 23.0.90 on Ubuntu 8.10 (x86_64)
Date: Tue, 10 Feb 2009 09:55:18 +0200
User-agent: Wanderlust/2.15.6 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/22.2 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)

Thank you for trying to build the GNUstep port.  I've been holding
these changes for far too long.

(I wonder why this message didn't get a bug number assigned?  Perhaps
because it was posted to the newsgroup first...)


2009-02-10  Yavor Doganov  <address@hidden>  (tiny change)

        * nsterm.m: Include <signal.h>.

        * nsfns.m (ns_appkit_version_int): Fix typo in the version macro.

Index: src/nsfns.m
===================================================================
RCS file: /sources/emacs/emacs/src/nsfns.m,v
retrieving revision 1.36
diff -u -r1.36 nsfns.m
--- src/nsfns.m 23 Jan 2009 09:58:03 -0000      1.36
+++ src/nsfns.m 10 Feb 2009 07:47:51 -0000
@@ -974,7 +974,7 @@
 ns_appkit_version_int ()
 {
 #ifdef NS_IMPL_GNUSTEP
-  return GNUSTEP_GUI_MAJOR_VERSION * 100 + GNUSTEP_GNU_MINOR_VERSION;
+  return GNUSTEP_GUI_MAJOR_VERSION * 100 + GNUSTEP_GUI_MINOR_VERSION;
 #elif defined(NS_IMPL_COCOA)
   return (int)NSAppKitVersionNumber;
 #endif
Index: src/nsterm.m
===================================================================
RCS file: /sources/emacs/emacs/src/nsterm.m,v
retrieving revision 1.58
diff -u -r1.58 nsterm.m
--- src/nsterm.m        7 Feb 2009 11:04:07 -0000       1.58
+++ src/nsterm.m        10 Feb 2009 07:47:54 -0000
@@ -30,6 +30,7 @@
 #include "config.h"
 
 #include <math.h>
+#include <signal.h>
 #include <sys/types.h>
 #include <time.h>
 #include <unistd.h>









reply via email to

[Prev in Thread] Current Thread [Next in Thread]