bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2577: 23.0.91; startup.el should choose .emacs ahead of .emacs.elc i


From: Alex
Subject: bug#2577: 23.0.91; startup.el should choose .emacs ahead of .emacs.elc if .emacs is newer
Date: Thu, 5 Mar 2009 09:44:40 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

Following on from discussion at:

http://curiousprogrammer.wordpress.com/2009/03/04/compiling-at-emacs-startup

I humbly submit the following bug report:

From:  <address@hidden>
To: address@hidden
Subject: 23.0.91; startup.el should choose .emacs ahead of .emacs.elc if .emacs 
is newer
--text follows this line--

Currently startup.el warns if .emacs.elc is newer than .emacs however
this hides subtle bugs if people don't carefully watch their logs/mode
line during startup. Although many people have clever auto-compile
magic every tiome they save .emacs this often break down when they
pull in updates via SCMs.

It should still warn, but by default it should go with the newest
version.

-- 
Alex, homepage: http://www.bennee.com/~alex/
It is far better to be deceived than to be undeceived by those we love.






reply via email to

[Prev in Thread] Current Thread [Next in Thread]