bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1333: 23.0; Emacs.app does not load ~/.emacs


From: Yavor Doganov
Subject: bug#1333: 23.0; Emacs.app does not load ~/.emacs
Date: Fri, 06 Mar 2009 23:19:24 +0200
User-agent: Wanderlust/2.15.5 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/22.3 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)

Adrian Robert wrote:
> Does this bug still exist?

Yes, unfortunately.

GNU Emacs 23.0.91 (i686-pc-linux-gnu, NS gnustep-gui-0.12.0) of
2009-03-06 on gana.yavor.doganov.org

You wrote some time ago (21 Nov 2008):

> Still, I would think not loading .emacs and trashing the env would
> be bugs that would be noticed that quickly.

I don't think so.  How many people you think build and run the GNUstep
port?  I tried Emacs.app before the merge two or three times, and it
was crashing immediately or drawing and expaniding the frame
horizontally && crashing all the time (basically what it does now
under GNOME with certain configurations, and with the GNUstep cairo
backend).  So I decided to wait until unicode-2 gets merged in Emacs
trunk, and Emacs.app after that.  I believe you that it worked before
the merge, and probably after the merge.  But the code changed
significantly after that.

I deliberately did not report the absolutely trivial problem in #2264;
it took about two months after someone reported it here and about 3
months after a prominent GNUstep user and maintainer reported in on a
GNUstep mailing list.  I know that this strategy is very bad, since
only a very small percentage of the users report bugs.  Anyway, my
point still holds, I think.  The only port that has less users is the
MS-DOG port.

So, in conclusion, very few people are trying to build, *run*, and
*use* the GNUstep port.  This should not be surprising to anyone.

I have identified some changes that look suspicious for this problem
(after the merge), but reverting them just either brings my machines
down when compiling Emacs, or does not fix the problem at all.

In general, I think that 99% of the problems for the GNUstep port are
due to CANNOT_DUMP.  Is there any other platform/system/whatever where
CANNOT_DUMP works (i.e. where it leads to an usable Emacs)?  My
general feeling is that this is the first port that is supposed to be
used in production, and the CANNOT_DUMP limitations simply cannot
provide that.






reply via email to

[Prev in Thread] Current Thread [Next in Thread]