bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2317: emacs silently ignores buffer file encoding?


From: Kenichi Handa
Subject: bug#2317: emacs silently ignores buffer file encoding?
Date: Wed, 18 Mar 2009 16:32:37 +0900

In article <address@hidden>, Sven Joachim <address@hidden> writes:

> On 2009-03-15 17:12 +0100, Chong Yidong wrote:
>>> (1) Start emacs -Q
>>> (2) Visit "/tmp/fff"
>>> (3) Insert the following chars: "θϑΘ"
>>> (4) Set the buffer file encoding to latin1 with: C-x C-m f latin-1 RET
>>> (5) Save the buffer: C-x C-s
>>> 
>>> For me, "/tmp/fff" is saved sucessfully, with no error or prompt, using
>>> an encoding of utf-8 -- despite my having explicitly requested latin-1.
> >
> > I think this bug may have been fixed.  ISTR seeing the same result when
> > I tested with your recipe a few weeks ago.  With latest CVS, however, I
> > get a "Select coding system" prompt.  Can you confirm?

> This has been fixed on March 3 by Handa-san, see [1].  However, this fix
> has side effects that I find very annoying: if I visit a file containing
> only ASCII characters and insert non-ASCII characters into the buffer,
> the "Select coding system" prompt pops up as well, although I never
> asked about a specific coding system and would be completely satisfied
> with Emacs silently choosing UTF-8[2] in that case.

Oops, this is surely a bad side effect.  I've just fixed it.

---
Kenichi Handa
address@hidden






reply via email to

[Prev in Thread] Current Thread [Next in Thread]