bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2786: marked as done (align-regexp -- no response)


From: Emacs bug Tracking System
Subject: bug#2786: marked as done (align-regexp -- no response)
Date: Fri, 27 Mar 2009 02:40:06 +0000

Your message dated Thu, 26 Mar 2009 22:34:33 -0400
with message-id <address@hidden>
and subject line Re: align-regexp -- no response
has caused the Emacs bug report #2786,
regarding align-regexp -- no response
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
2786: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=2786
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: align-regexp -- no response Date: Thu, 26 Mar 2009 22:09:55 +0900

My system: Windows Xp SP3(32bit), ntEmacs 23.0.0.1 (i386-mingw-nt5.1.2600)

 

My file's content is like below.

Notice that the first character of the first line is a whitespace,

and the first character of the second line is not a whitespace.

 

 This is my text file.

This is my text file.

 

 

Aaginst this text, I gave a command.

 

M-x align-regexp RET

 

When minibuffer shows "Align regexp: ", I just struck Retern key without giving any regular _expression_.

And then Emacs doesn't response any more. Is this a bug?

 

Reproduction scenario

1. The first character of your file's first line begins a whitespace.

2. The first character of your file's second line begins a non-whitespace character.

3. After the M-x align-regexp command, just strike Return key without giving any regular _expression_.

 

Result: Emacs doesn't response any more. You should kill the process of Emacs.

 

Good luck to you all. Long live GNU, Linux, Emacs!!  :-)


--- End Message ---
--- Begin Message --- Subject: Re: align-regexp -- no response Date: Thu, 26 Mar 2009 22:34:33 -0400
> My system: Windows Xp SP3(32bit), ntEmacs 23.0.0.1
> (i386-mingw-nt5.1.2600)
 
> My file's content is like below. 
> Notice that the first character of the first line is a whitespace, 
> and the first character of the second line is not a whitespace.
> 
>  This is my text file.
> This is my text file.
> 
> M-x align-regexp RET
> 
> When minibuffer shows "Align regexp: ", I just struck Retern key
> without giving any regular expression.  And then Emacs doesn't
> response any more.

Thanks for the bug report.  This has actually been fixed in CVS already
(Bug#1982).


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]