bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3996: marked as done (Perl highlighting in perl-mode and cperl-mode)


From: Emacs bug Tracking System
Subject: bug#3996: marked as done (Perl highlighting in perl-mode and cperl-mode)
Date: Sun, 16 Aug 2009 00:55:05 +0000

Your message dated Sat, 15 Aug 2009 20:47:48 -0400
with message-id <address@hidden>
and subject line Re: Perl highlighting in perl-mode and cperl-mode
has caused the Emacs bug report #3996,
regarding Perl highlighting in perl-mode and cperl-mode
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
3996: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3996
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Perl highlighting in perl-mode and cperl-mode Date: Fri, 31 Jul 2009 12:07:14 +0000 In GNU Emacs 21.3.1 (x86_64-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
of 2006-05-02 on hs20-bc1-4.build.redhat.com
configured using `configure --build=x86_64-redhat-linux --host=x86_64-redhat-linux --target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --with-pop --with-sound'
Important settings:
value of $LC_ALL: nil
value of $LC_COLLATE: nil
value of $LC_CTYPE: nil
value of $LC_MESSAGES: nil
value of $LC_MONETARY: nil
value of $LC_NUMERIC: nil
value of $LC_TIME: nil
value of $LANG: en_US.UTF-8
locale-coding-system: utf-8
default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

In code such as:

$output =~ /default device is `(.*)'/

everything after the "`" (to the end of the buffer) is incorrectly coloured as string.
--- End Message ---
--- Begin Message --- Subject: Re: Perl highlighting in perl-mode and cperl-mode Date: Sat, 15 Aug 2009 20:47:48 -0400
> In GNU Emacs 21.3.1 (x86_64-redhat-linux-gnu, X toolkit, Xaw3d scroll
> bars)...
>
> In code such as:
>
> $output =~ /default device is `(.*)'/
>
> everything after the "`" (to the end of the buffer) is incorrectly
> coloured as string.

Thanks for the bug report.  This bug is fixed in newer version of Emacs.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]