[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#4134: 23.1; Buffer Tab not being linked properly

From: David Ronis
Subject: bug#4134: 23.1; Buffer Tab not being linked properly
Date: Thu, 20 Aug 2009 22:21:50 -0400

I figured out what the problem is.  I'm running slackware 12.2 which no
longer supports gnome.  To have gnome, I use the garnome build system
(which basically installs everything gnome needs into a separate tree).
Since, some (usually older) components exist in the system, garnome uses
environment variables like PATH and LD_LIBRARY_PATH to make sure that
the garnome versions of various libraries, programs are found first.

When I build basic system utilities (emacs is one of them), I break out
of garnome (by unsetting environment variables) and build/install.  As
such emacs links against slackware's libs.  Even so, running in the
garnome environment still worked, until now.  In fact, my problem goes
away if I run in the garnome-free environment, and I can hack a fix, by
calling emacs from a script.

Since I'm usually running gnome, I rebuilt emacs in the garnome
environment.  The build completed, but the resulting emacs has the
problem.  My bet is that one of the more recent gnome libs (probably gtk
+) is at fault.  I'm using gtk+2.17.8 here.  

Any suggestions how to pin this down?  I build garnome with -O2 -g so
debugging sessions are possible.

Here's  a list of the garnome versions used by emacs:

        libgtk-x11-2.0.so.0 => /opt/gnome/lib/libgtk-x11-2.0.so.0 (0xb7b19000)
        libgdk-x11-2.0.so.0 => /opt/gnome/lib/libgdk-x11-2.0.so.0 (0xb7a6d000)
        libatk-1.0.so.0 => /opt/gnome/lib/libatk-1.0.so.0 (0xb7a50000)
        libpangoft2-1.0.so.0 => /opt/gnome/lib/libpangoft2-1.0.so.0
        libgdk_pixbuf-2.0.so.0 => /opt/gnome/lib/libgdk_pixbuf-2.0.so.0
        libpangocairo-1.0.so.0 => /opt/gnome/lib/libpangocairo-1.0.so.0
        libgio-2.0.so.0 => /opt/gnome/lib/libgio-2.0.so.0 (0xb78fd000)
        libXcursor.so.1 => /opt/gnome/lib/libXcursor.so.1 (0xb78c7000)
        libXrender.so.1 => /opt/gnome/lib/libXrender.so.1 (0xb78b9000)
        libcairo.so.2 => /opt/gnome/lib/libcairo.so.2 (0xb7834000)
        libpango-1.0.so.0 => /opt/gnome/lib/libpango-1.0.so.0 (0xb768e000)
        libfreetype.so.6 => /opt/gnome/lib/libfreetype.so.6 (0xb7614000)
        libfontconfig.so.1 => /opt/gnome/lib/libfontconfig.so.1 (0xb75cc000)
        libgobject-2.0.so.0 => /opt/gnome/lib/libgobject-2.0.so.0 (0xb7588000)
        libgmodule-2.0.so.0 => /opt/gnome/lib/libgmodule-2.0.so.0 (0xb7584000)
        libglib-2.0.so.0 => /opt/gnome/lib/libglib-2.0.so.0 (0xb74a4000)
        libXft.so.2 => /opt/gnome/lib/libXft.so.2 (0xb7385000)
        librsvg-2.so.2 => /opt/gnome/lib/librsvg-2.so.2 (0xb7289000)
        libdbus-1.so.3 => /opt/gnome/lib/libdbus-1.so.3 (0xb7230000)
        libpixman-1.so.0 => /opt/garnome-svn-2.27/lib/libpixman-1.so.0
        libglitz.so.1 => /opt/garnome-svn-2.27/lib/libglitz.so.1 (0xb6f23000)
        libexpat.so.1 => /opt/garnome-svn-2.27/lib/libexpat.so.1 (0xb6ec7000)
        libgsf-1.so.114 => /opt/garnome-svn-2.27/lib/libgsf-1.so.114
        libcroco-0.6.so.3 => /opt/garnome-svn-2.27/lib/libcroco-0.6.so.3
        libxml2.so.2 => /opt/garnome-svn-2.27/lib/libxml2.so.2 (0xb6cfa000)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]