[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#4259: Cannot indent fortran continue statement in emacs 23

From: Ushnish Basu
Subject: bug#4259: Cannot indent fortran continue statement in emacs 23
Date: Tue, 25 Aug 2009 12:09:30 -0700
User-agent: Thunderbird (X11/20090812)


I believe I came across a bug in the latest version of the fortran mode in emacs 23. Currently I am using version 23.1.1, but I did not have this problem with 23.0.60 from CVS.

Please see the following sample code - I have arranged it as such only to illustrate the problem:

      subroutine first
      do 10 i=1,10
 10     continue
      do 20 i=1,100
 20     continue

If I run fortran-indent-line on the first continue (label 10) it works fine. However, if I run it on the second one (label 20), I get the error:

fortran-check-end-prog-re: Lisp nesting exceeds 'max-lisp-eval-depth'

presumably because it is after the 'end'

If I increase max-lisp-eval-depth (and max-specpdl-size) to 10000, then I get the error

fortran-check-end-prog-re: Variable binding depth exceeds max-specpdl-size

Is this something that has been fixed in CVS?

I look forward to hearing back from you.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]