[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#5541: 23.1; after upgrading to emacs-23, meta key in xterm no longer

From: Jim Paris
Subject: bug#5541: 23.1; after upgrading to emacs-23, meta key in xterm no longer works
Date: Sun, 07 Feb 2010 14:55:33 -0500

With "emacs23 -nw" running inside xterm-253, my meta key does not work
for things like M-x.  Instead, the terminal bell beeps, and the string
;120~ appears in the buffer.  Looking at the log below, this is
because the terminal actually sent the string \e[27;3;120~ which is
occurring because emacs turned on the "modifyOtherKeys" setting with
the escape sequence \e[>4;1m at startup.  Older versions of emacs did
not do this, and everything worked fine.

Indeed, if I execute the command:
   (xterm-turn-off-modify-other-keys (selected-frame))
then my meta key temporarily starts working again.

My normal Xterm settings are
  xterm*metaSendsEscape: true
  xterm*eightBitInput: false
which has always worked in previous versions.

This new "modifyOtherKeys" stuff causes plenty of other problems too,
like the string "0;235;0c" (xterm identification response?) sometimes
appearing in my buffer at startup if the system is heavily loaded or
I'm on a slow connection, and the input buffer getting flushed at
startup, so I lose stuff I typed while emacs was loading.  Could a
knob be added to just get rid of it completely?


In GNU Emacs 23.1.1 (x86_64-pc-linux-gnu, GTK+ Version 2.18.3)
 of 2009-11-01 on excelsior, modified by Debian
configured using `configure  '--build=x86_64-linux-gnu' 
'--host=x86_64-linux-gnu' '--prefix=/usr' '--sharedstatedir=/var/lib' 
'--libexecdir=/usr/lib' '--localstatedir=/var/lib' '--infodir=/usr/share/info' 
'--mandir=/usr/share/man' '--with-pop=yes' 
 '--with-x=yes' '--with-x-toolkit=gtk' '--with-toolkit-scroll-bars' 
'build_alias=x86_64-linux-gnu' 'host_alias=x86_64-linux-gnu' 'CFLAGS=-DDEBIAN 
-g -O2' 'LDFLAGS=-g' 'CPPFLAGS=''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  value of $XMODIFIERS: nil
  locale-coding-system: utf-8-unix
  default-enable-multibyte-characters: t

Major mode: Text

Minor modes in effect:
  tooltip-mode: t
  tool-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  global-auto-composition-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:
ESC [ > 0 ; 2 3 5 ; 0 c a s d f RET ( x t e r m - t 
u r n - o f f - m o d i f y - o t h e r - k e y s SPC 
( s e l e c t e d - f r a m e ) ) RET C-x C-s C-g ESC 
[ 2 7 ; 3 ; 1 2 0 ~ C-p C-e C-n C-p C-x C-e C-n ESC 
x C-g RET RET ESC x r e p o r t - b u g RET C-g ESC 
x r e p o t - e m DEL DEL DEL DEL r t - e m a TAB 

Recent messages:
Loading /etc/emacs/site-start.d/50psvn.el (source)...done
Loading /etc/emacs/site-start.d/51debian-el.el (source)...done
Loading /etc/emacs/site-start.d/70jim.el (source)...
Toggling menu-bar-mode off; better pass an explicit argument.
Loading /etc/emacs/site-start.d/70jim.el (source)...done
Loading quail/latin-ltx...done
Quit [2 times]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]