bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#6993: Enabling Flyspell mode gave an error


From: Agustin Martin
Subject: bug#6993: Enabling Flyspell mode gave an error
Date: Tue, 7 Sep 2010 17:54:31 +0200
User-agent: Mutt/1.5.20 (2009-06-14)

On Tue, Sep 07, 2010 at 10:48:47PM +0800, address@hidden wrote:
> $ emacs -Q -nw -f flyspell-mode
> Enabling Flyspell mode gave an error
> $ apt-cache policy emacs-snapshot
>   Installed: 1:20100903-2

Hi, Dan,
 
If you are using Debian emacs-snapshot please test

$ emacs-snapshot  -Q -nw -f flyspell-mode

That is causing no problems here (1:20100903-2 too).

Note that a similar error recently happened in Debian with normal Emacs 
(not the snapshots) because of change in options for (called-interactively-p) 
between emacs23.1 and 23.2, when upgrading to a more recent flyspell.el 
from FSF Emacs bzr repo. 

I currently use in Debian

(condition-case nil                      ;; XEmacs does not have 
`called-interactively-p',
   (called-interactively-p 'interactive) ;; emacs23.1 does not allow option and 
emacs23.2
             (error (interactive-p))))   ;; needs it and mark `interactive-p' 
obsolete

to make that work for all, but since 23.1 is not to be shipped I may change
it back to something like

(if (fboundp 'called-interactively-p)
         (called-interactively-p 'interactive)
      (interactive-p))

to keep XEmacs happy.  One of both may go into FSF Emacs bzr to decrease
XEmacs incompatibilities. Suggestions welcome.

Please confirm if problem persists when explicitly using emacs-snapshot.

-- 
Agustin






reply via email to

[Prev in Thread] Current Thread [Next in Thread]