[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#7905: 24.0.50; VC not updating file status properly anymore after co

From: Tim Van Holder
Subject: bug#7905: 24.0.50; VC not updating file status properly anymore after commit from vc-dir
Date: Tue, 25 Jan 2011 12:30:02 +0100

On 25 January 2011 10:44, Tim Van Holder <address@hidden> wrote:
> On 25 January 2011 09:00, Tim Van Holder <address@hidden> wrote:
>> I'll re-bootstrap emacs to ensure the compiled lisp files are properly
>> in sync, and I'll try to set up a scenario with emacs -Q.
> After bootstrap, a commit on 2 files in "added" state changed them to
> "edited" state (instead of up-to-date). So there is _some_ state
> changing still happening.
> I tried a further multi-file commit with emacs -Q; this did change the
> state to up-to-date, so it looks like it's an interaction with some
> setting somewhere. I'll try to hunt it down.

This is very odd. With "emacs -q --no-site-file --no-site-lisp" (i.e.
-Q but without the --no-splash) it still doesn't work, but with "emacs
-q --no-splash" it does, so the --no-splash by itself has a positive
"emacs --no-splash" also works, but only if I disable loading of my
customize settings.
By a process of elimination, it turns out that the
  '(display-time-mode t)
line in (custom-set-variables) is the culprit. With that removed,
things work, even without --no-splash.

I'm attaching a tarball with a dummy CVS repos; my tests used:

  mkdir -p /wherever/you/want
  cd /wherever/you/want
  tar xzvf /somewhere/emacs-7905.tar.gz
  ./reset   # resets the dummy repos and checks out a sandbox with two
newly-added files
  emacs <command line options>
     [C-x v d] sandbox
     foo[C-c C-c]

And then the two files are either edited or up-to-date, depending on
whether the issue presents itself or not.

Attachment: emacs-7905.tar.gz
Description: GNU Zip compressed data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]