[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#7962: 23.2; capitalize letters ISO-8859-1 [SOLVED, MANY THANKS TO AL

From: Emmanuel Bigler
Subject: bug#7962: 23.2; capitalize letters ISO-8859-1 [SOLVED, MANY THANKS TO ALL]
Date: Sat, 05 Feb 2011 10:27:19 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101209 Fedora/3.1.7-0.35.b3pre.fc14 Thunderbird/3.1.7

Le 04/02/2011 22:34, Stefan Monnier a écrit :
So that leads me to think the buffer is in unibyte mode.
If you started with "emacs -Q", the only explanation is that you have
EMACS_UNIBYTE set in your environment variables.  If that's the case,
then please get rid of it.

*THANKS, Stefan !*

I had this (!!$£%!µÞЬ¬!!) variable set in my shell environment
variables from older emacs releases.

Getting rid of it solved the problem.
So it was not a bug, but a feature ;-)

I think that we can now say *IN CAPITAL LETTERS* :

*[FEATURE CLOSED]* (since this was not a bug ;-)

And this also solved another problem I had noticed : ispell was
pretending to use 2-byte characters instead of the 1-byte ISO-8859 I
was using.

Thanks to all for your time !

Now the only pending isssue is whether I'll convert my files to UTF-8
some day ; ahem... now that my faithful emacs does exactly what I
want, I do not see any reason to do it soon, I like to be obsolete to
some extent ;-)

All the best !


reply via email to

[Prev in Thread] Current Thread [Next in Thread]