[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#8562: Emacs 23.1 and later don't work in windows 98

From: oslsachem
Subject: bug#8562: Emacs 23.1 and later don't work in windows 98
Date: Fri, 6 May 2011 03:38:46 +0200

> Which suggested solution is that?  There were 2 in that thread.

To be honest, I only tried the first one ("start Emacs from the
command-line as: emacs -Q -xrm Emacs.fontBackend:gdi") because:

- I deemed them to be functionally equivalent.

- The second solution involves editing the windows registry (which is
a frail but essential part of the system).

- Emacs doesn't seem to add any entry to the windows registry after
running the "addpm.exe" as opposed to what is stated at

- The "set Emacs.fontBackend in the registry" indication is too terse
for me to understand.

> Anyway, Emacs developers need help to debug this, as none of us has
> access to a Windows 9X machine anymore.  If you are willing to work
> with us, I'm sure we will find the solution.

Of course, just tell me what I have to do :).

Here you have "updated" screenshots of what Emacs-23.3 looks like in
windows 98 when started in GUI mode:

Initial size:


Maximized size:


File submenu:


Edit submenu:


The Options and Buffers submenus look hidden but are there:



Emacs abort dialog when it eventually has a fatal error:


Spanish version of Windows 98 error message:  "This program has
performed an illegal operation and will be shut down.  If the problem
persists, contact the program vendor. [Close] [Details]":
Inside the text box, spanish version of Windows 98 error message:
"EMACS caused an invalid page fault in module EMACS.EXE".

     First part:


    Second part:


In the meantime, I've been skimming through the instructions about
compiling and debugging Emacs and I have managed to build Emacs
succesfully and run it using the debugger.

Here is a log of the debugger after spending a while fiddling with the
Emacs submenus until a fatal error happens:


Notice that I run Emacs more than once and that, the last time,
running Emacs using the suggested solution doesn't produce any
noticeable difference (i.e the fatal error is the same).

Note: I tried to build Emacs using the --no-opt option for configure
but when trying to run Emacs using the debugger, gdb produced an error
("internal-error: virtual memory exhausted: can't allocate ..........
bytes. A problem internal to GDB has been detected, further debugging
may prove unreliable") so I have built Emacs without --no-opt ( I
guess that is why the executables end up in oo-spd/i386 instead of

Unrelated note:
Sorry for the poor text format of my previous message.  I failed to
notice that I was using rich text format instead of plain text.
Hopefully this message will look better.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]