bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9017: 24.0.50; gnutls.c: [0] (Emacs) fatal error: Key usage violatio


From: Ted Zlatanov
Subject: bug#9017: 24.0.50; gnutls.c: [0] (Emacs) fatal error: Key usage violation in certificate has been detected.
Date: Fri, 15 Jul 2011 14:56:47 -0500
User-agent: Gnus/5.110018 (No Gnus v0.18) Emacs/24.0.50 (gnu/linux)

On Fri, 15 Jul 2011 06:16:14 -0500 "Roland Winkler" <address@hidden> wrote: 

RW> In a site-wide installation of emacs it is more likely that one or
RW> the other emacs user finds himself in the situation that he needs to
RW> run gnutls with whatever special option that might be more difficult
RW> to achieve with the new builtin gnutls code. So it might be good to
RW> have an option for disabling this builtin code in a cleaner way than
RW> redefining the builtin function gnutls-available-p.

I think there should be no such situations; the command-line GnuTLS
tools are insecure and unreliable and should not have to be used.  As
with the priority string option, whatever options users need should get
added.  I see those cases as bugs rather than feature requests.

Again, sorry I haven't looked at any of the GnuTLS or other bugs in
weeks, but I should be back in 10 days or so and will make an effort to
work through the backlog.

Ted





reply via email to

[Prev in Thread] Current Thread [Next in Thread]