[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9167: 24.0.50; error: "Buffer name ` **lose**' is not in use"

From: Drew Adams
Subject: bug#9167: 24.0.50; error: "Buffer name ` **lose**' is not in use"
Date: Sun, 24 Jul 2011 17:05:13 -0700

This is the build I'm reporting the bug for (but I'm using another build
to report it because of the recent breakage of bug-report mailing due to
the SMTP config silliness - PLEASE FIX THAT):
In GNU Emacs (i386-mingw-nt5.1.2600)
 of 2011-07-18 on 3249CTO
Windowing system distributor `Microsoft Corp.', version 5.1.2600
configured using `configure --with-gcc (4.5) --no-opt --cflags
I don't have a recipe from emacs -Q.  This happened when using my setup.
I modified a file buffer by making some text invisible.  I then tried to
do `find-alternate-file' for the same file (since simply reverting does
not revert all changes).  
I got this message, to which I replied `no':
Buffer icicles-cmd2.el is modified; save it first? (yes or no)
I got this message, to which I replied `yes':
Kill and replace the buffer without saving it? (yes or no)
The buffer disappeared and I got this
Debugger entered--Lisp error: (error "Buffer name ` **lose**' is in use")
  rename-buffer(" **lose**")
  find-alternate-file("c:/drews-lisp-20/icicles-cmd2.el" t)
  call-interactively(find-alternate-file nil nil)
I tried again, just after that, in the same session, after `C-x 4 f
icicles-cmd2.el', which visited the same modified buffer (since I had
not killed it and the dialog apparently did not either).  Same exact
dialog and debugger backtrace was repeated.  I killed the buffer myself
and was able to continue (revisit the file).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]