bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9177: [PATCH] 24.0.50: configure should allow building with librsvg


From: Alp Aker
Subject: bug#9177: [PATCH] 24.0.50: configure should allow building with librsvg on Mac
Date: Tue, 26 Jul 2011 16:45:01 -0400

When configuring --with-ns, one can also specify --with-rsvg, but the
latter option is respected only if building on GNUstep; it is ignored
when building on Darwin.  The restriction is unnecessary: if librsvg
is present, Emacs will build on Darwin and display svg images without
a problem. The following small change to configure.in would remove
this restriction.

2011-07-26  Alp Aker  <address@hidden>

        * configure.in (HAVE_RSVG): Allow use of -lrsvg-2 for any NextStep
        build, not just GNUstep.

=== modified file 'configure.in'
--- configure.in        2011-07-13 10:36:12 +0000
+++ configure.in        2011-07-26 20:20:06 +0000
@@ -1821,7 +1821,7 @@

 ### Use -lrsvg-2 if available, unless `--with-rsvg=no' is specified.
 HAVE_RSVG=no
-if test "${HAVE_X11}" = "yes" || test "${NS_IMPL_GNUSTEP}" = "yes"; then
+if test "${HAVE_X11}" = "yes" || test "${HAVE_NS}" = "yes"; then
   if test "${with_rsvg}" != "no"; then
     RSVG_REQUIRED=2.11.0
     RSVG_MODULE="librsvg-2.0 >= $RSVG_REQUIRED"





reply via email to

[Prev in Thread] Current Thread [Next in Thread]