bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9392: 24.0.50; rmail-forward produces messages in unsupported format


From: Eli Zaretskii
Subject: bug#9392: 24.0.50; rmail-forward produces messages in unsupported format that cannot be customized away
Date: Mon, 29 Aug 2011 01:17:39 -0400

> Date: Mon, 29 Aug 2011 05:55:43 +0300
> From: Eli Zaretskii <address@hidden>
> Cc: address@hidden
> 
> > *Note (emacs-mime) MML Definition::
> 
> Thanks.  So you are saying that the _actual_ bug is that rmail-forward
> doesn't run the outgoing message buffer through mml-generate-mime, is
> that right?

Actually, I should have told that the original problem happens with
mail-user-agent set to sendmail-user-agent.

So, given the above input regarding MML, I assumed that message.el
does TRT with MML before sending the forwarded message, and tried
rmail-forward in "emacs -Q".  However, with that configuration, the
code which inserts the MML "<#part ...>" tag is never executed, and in
fact the "*unsent mail*" buffer popped by message.el does not have the
text of the message being forwarded; the body of the composed message
is empty.

AFAICS, the "<#part ...>" tag is not inserted because rmail-forward
expects rmail-start-mail return a non-nil value, but with
message-user-agent it returns nil.

So it looks like message-user-agent is incompatible with
rmail-forward, or else I'm doing something terribly wrong.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]