bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9889: 24.0.90; emacsclient fails to start on OSX


From: Randal L. Schwartz
Subject: bug#9889: 24.0.90; emacsclient fails to start on OSX
Date: Fri, 28 Oct 2011 12:45:39 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (berkeley-unix)

>>>>> "Randal" == Randal L Schwartz <address@hidden> writes:

>>>>> "Stefan" == Stefan Monnier <address@hidden> writes:
>>> But this worked before, so something has changed.

Stefan> Could be that the TMPDIR has changed.

Randal> I don't think so.  The emacsclient is being invoked from within a shell
Randal> window in the emacs.  So I know they share the same $TMPDIR, and in
Randal> fact, in $TMPDIR, I see the socket.

Stefan> But also emacsclient/server used
Stefan> to ignore TMPDIR.  I can't remember when this was changed (I think it
Stefan> was in Emacs-23).

Randal> Well, I know it worked about a month ago, and I've been tracking HEAD.
Randal> I guess I'll have to try to bisect this out.  Lots of long compiling
Randal> ahead for me. :(

Ugh, I rolled back a whole year, and it still failed.

Then I started poking around... apparently, I was picking up
/usr/bin/emacsclient somehow instead of the emacsclient I had been
building.  Something is reinserting /bin:/usr/bin in front of my PATH as
a subshell is starting.  Once I forced the proper emacsclient,
everything worked again.

So, no bug... just a stupid config problem that I still have to sort out.

-- 
Randal L. Schwartz - Stonehenge Consulting Services, Inc. - +1 503 777 0095
<address@hidden> <URL:http://www.stonehenge.com/merlyn/>
Smalltalk/Perl/Unix consulting, Technical writing, Comedy, etc. etc.
See http://methodsandmessages.posterous.com/ for Smalltalk discussion





reply via email to

[Prev in Thread] Current Thread [Next in Thread]