bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9814: 23.3; unguarded setq of default-directory in ido.el


From: Dave Abrahams
Subject: bug#9814: 23.3; unguarded setq of default-directory in ido.el
Date: Mon, 31 Oct 2011 11:24:18 -0800
User-agent: Gnus/5.110018 (No Gnus v0.18) Emacs/23.3 (darwin)

on Fri Oct 28 2011, Chong Yidong <cyd-AT-gnu.org> wrote:

> Dave Abrahams <address@hidden> writes:
>
>> I'm sorry that I don't have a reproducer at the moment.  I was having
>> some failures during startup that would leave my Emacs unable to change
>> buffers with `M-x switch-to-buffer', which was remapped to
>> ido-switch-buffer, because it would attempt to make a Tramp connection
>> to some nonexistent host.  I could get around this by `M-: (setq
>> default-directory "~")', so I went hunting in ido.el for mentions of
>> default-directory and found 2 instances of (setq default-directory...)
>> that were not apparently surrounded by a let.  This seems like a likely
>> cause of the problem.
>
> I'm not too familiar with ido, and do not know whether those setqs are
> intentional.  Could you try let-binding default-directory in those
> locations and test it out for a while, and see if there is any effect?

I've made the changes... I guess the best report you can expect, unless
I get myself into trouble at startup again, is that it has no effect.
Will you check back with me in a week?

-- 
Dave Abrahams
BoostPro Computing
http://www.boostpro.com





reply via email to

[Prev in Thread] Current Thread [Next in Thread]