[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10034: 24.0.91; max-specpdl-size error

From: nyc4bos
Subject: bug#10034: 24.0.91; max-specpdl-size error
Date: Sun, 13 Nov 2011 18:01:42 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.91 (windows-nt)

martin rudalics <address@hidden> writes:

>> Eventually, I would get into a state where I couldn't do much, seeing
>> messages like:
>> window-min-size-1: Variable binding depth exceeds max-specpdl-size
>> I then could only kill Emacs.
> Do you mean that Emacs looped and C-g didn't quit?  If you can see a
> message like the above, C-g usually works.

C-g worked. However, other things that I did resulted in
"Variable binding depth exceeds max-specpdl-size" messages.

>> In GNU Emacs (i386-mingw-nt5.1.2600)
>>  of 2011-11-07 on MARVIN
> IIUC this is with a build made _before_ Chong's `window-total-size'
> change, so the latter can't be the culprit.

I was using the "emacs-20111107-r106319-bin-i386.zip" Windows version.

> I can't propose much about this at the moment.  If this happens again
> and you can get back to the command loop via C-g, try to open a new
> frame via C-x 5 2 and look at the last lines of the *Messages* buffer.
> If for some reason you can't make a new frame, try C-x 1 instead.

The specific error message that I listed above:

  window-min-size-1: Variable binding depth exceeds max-specpdl-size

occurred when I tried to `C-SPC C-h M-w' the *Message* buffer.

When I was geting different "max-specpdl-size" errors with almost
everything I subsequently did, I started up a new Emacs instance in
order to file a bug report.

I then tried to copy the *Message* buffer from the original Emacs
instance that was having this problem into the new Emacs instance in
order to provide information for the bug report.

I could `C-x b' (switch-to-buffer) to the *Message* buffer and a few
other things but most things resulted in different "max-specpdl-size"
warning messages.

(BTW, I noticed that after sending a bug report and successfully
sending with `C-c C-c', the Bug Report Help buffer created when
invoking `(report-emacs-bug)' at least from the menu-bar, remains
visible as another (split) window.  Is that intentional?)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]