bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11257: http://thread.gmane.org/gmane.emacs.orgmode/54775


From: Marius Hofert
Subject: bug#11257: http://thread.gmane.org/gmane.emacs.orgmode/54775
Date: Fri, 20 Apr 2012 23:48:50 +0200

Hi,

I could finally manage to compile Emacs from source. This is something I wanted 
to do already half a year ago, but it didn't work (many errors) and I didn't 
know how to fix this. This is how I came to http://emacsformacosx.com/builds. 
But thanks to the post on 
http://carlgroner.me/Emacs/OSX/2011/10/19/Building-Emacs-for-Mac-OSX-Lion.html
It finally worked without flaws. I worked with Emacs the whole day today and 
did not experience a single crash. I hope it remains like this :-). 
My guess is that the final problem came from the fact that the Emacs I 
originally used was built under 10.6.8 and I ran it on 10.7.3. Why the 
log-files from Console.app showed org-mode is still strange to me, but I'm 
definitely not an expert on these issues.

I'll get back to you if I experience another crash. For now, it seem's good.

Cheers,

Marius

On 2012-04-18, at 16:57 , Chong Yidong wrote:

> Marius Hofert <address@hidden> writes:
> 
>> I used "M-x set-variable <RET> debug-on-error <RET> t" to set Emacs in
>> debug mode. After this change, I just changed buffers until it crashed
>> again. I thought I'm lucky but apparently not: How do I obtain a
>> "Backtrace buffer" when Emacs crashes... ? After a restart, there was
>> no such buffer :-(
> 
> You have to compile Emacs from source, start Emacs from inside GDB from
> inside the Emacs src/ directory (run "gdb emacs", then "r" at the GDB
> prompt), and trigger the crash.  Then use the command "bt" in GDB to
> view the backtrace.

ETH Zurich
Dr. Marius Hofert
RiskLab, Department of Mathematics
HG E 65.2
Rämistrasse 101
8092 Zurich
Switzerland

Phone +41 44 632 2423
address@hidden
http://www.math.ethz.ch/~hofertj






reply via email to

[Prev in Thread] Current Thread [Next in Thread]