[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#8368: 24.0.50; "temp" means "help" - rename or at least document

From: Drew Adams
Subject: bug#8368: 24.0.50; "temp" means "help" - rename or at least document
Date: Sun, 29 Apr 2012 08:28:04 -0700

> You don't have to remove and re-add any hooks.  It's 
> sufficient to turn off help mode in the body of 
> `with-output-to-temp-buffer'.  Similarly,
> if you don't want to run `completion-list-mode-finish', turn off
> `completion-list-mode' in the buffer.

Sufficient?  That sounds like more work, not less.  Why turn help mode etc. on
automatically and then turn it off again.  Why not just remove the hook so it
does not get turned on?  I'm probably missing something in what you're

>  > Probably we will need to leave the original name for the 
>  > current behavior, but if it could be aliased to something
>  > with "help" in the name, and then the original name deprecated,
>  > that would be better.  (I think that's part of what
>  > you suggest.)  And create a new name for the 
>  > temp-without-the-help-stuff case.
> Basically, `with-output-to-temp-buffer' is a misnomer.  The 
> buffer is not necessarily temporary, hence
> `with-output-temporarily-bound-to-buffer'
> would be a better name for this.

True, but I don't really have a problem with that.  "Temporary" can mean
different things depending on the use to which this is put.  A buffer that I
display showing some information might be considered temporary if the user is
likely to throw it away soon after seeing the info.  At another extreme, a
temporary buffer might be one that a program uses without ever displaying and
kills when done.

> In addition, it displays the buffer in
> some window and this is not reflected in the name.

True again.  This point is more important, IMO, than the "temporary" point.  It
would be good for the name to indicate that the buffer is shown to the user.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]