bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11389: 24.0.96; Emacs not using the MS Windows clipboard


From: Gallagher, Kevin
Subject: bug#11389: 24.0.96; Emacs not using the MS Windows clipboard
Date: Tue, 1 May 2012 14:59:26 -0500

Sorry I wasn't detailed enough.

I have Windows XP Professional, SP3, installed on my pc at work. I've tested 
two scenarios, as follows: 1, 2, and then 1, again.

(1) I start up Emacs with -Q using runemacs.exe from a command line window. I 
then start up MS Word 2007, SP3. I type in "This is a test." into a blank word 
document, highlight the text with the mouse, and copy it with a Ctrl-C.  I move 
the mouse pointer to the Emacs window, click the left mouse button to get 
focus, and then press the middle mouse button. This time, and ONLY this time, 
the copied text appears in the Emacs buffer.  All subsequent attempts to copy 
text in either direction between Emacs and Word fail.

(2) I restart Emacs and Word as in 1, above. This time I type "This is text in 
Emacs." into the Emacs Scratch buffer and highlight with the mouse.  I then 
move the mouse pointer to the Word window, click the left mouse button to get 
focus, and type Ctrl-V.  The text I highlighted in Emacs is NOT pasted into the 
Word document. Instead, the most recent copied text from a non-Emacs program 
appears. At this point, any attempt to copy from the Word document to an Emacs 
buffer fails.

The second run of scenario 1 behaves just as it did the first time.


-----Original Message-----
From: Eli Zaretskii [mailto:address@hidden 
Sent: Tuesday, May 01, 2012 2:19 PM
To: Gallagher, Kevin
Cc: address@hidden
Subject: Re: bug#11389: 24.0.96; Emacs not using the MS Windows clipboard

> From: "Gallagher, Kevin" <address@hidden>
> Date: Tue, 1 May 2012 13:04:01 -0500
> 
> The Emacs 24.x pretests, when built on MS Windows, are not using the 
> MS Windows clipboard. (Giving the amount of testing I've done on the 
> earlier pretests, I'm surprised I didn't notice this sooner!)

Please show your evidence: some kind of series of steps, starting with "emacs 
-Q", which would show that the clipboard "is not used".

I'm using the 24.x pretests, and they all do use the Windows clipboard.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]