bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11410: 24.1.50; package.el `emacs' package information is broken


From: Chong Yidong
Subject: bug#11410: 24.1.50; package.el `emacs' package information is broken
Date: Sun, 06 May 2012 12:06:37 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.96 (gnu/linux)

Stefan Monnier <address@hidden> writes:

>> Surely the idea is for packages to refuse to even *install* under Emacs
>> versions where they won't work (package.el displays an "emacs x.x not
>> available" in this case.)
> [...]
>> That seems like a useful feature to me.
>
> Preventing users to do what they want doesn't sound useful to me

All the same, previous versions of package.el did handle the `emacs'
package, and the current version not doing so is a bug.  I've committed
a fix to trunk.

I agree that there should be an easy way to tell the package manager to
ignore package dependencies, but such a mechanism should apply to all
packages and not just the `emacs' package.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]