bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11813: bug#11850: crash (null font) running emacs built from git


From: Chong Yidong
Subject: bug#11813: bug#11850: crash (null font) running emacs built from git
Date: Sun, 08 Jul 2012 22:20:01 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.1.50 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

> OK, then does the following patch fix the problem?
>
> --- src/xdisp.c       2012-07-05 16:28:34 +0000
> +++ src/xdisp.c       2012-07-05 16:51:53 +0000
> @@ -22604,7 +22604,7 @@ fill_glyphless_glyph_string (struct glyp
>    last = s->row->glyphs[s->area] + end;
>    voffset = glyph->voffset;
>    s->face = FACE_FROM_ID (s->f, face_id);
> -  s->font = s->face->font;
> +  s->font = s->face->font ? s->face->font : FRAME_FONT (s->f);
>    s->nchars = 1;
>    s->width = glyph->pixel_width;
>    glyph++;

This patch is correct, please commit it.  Indeed, when creating
glyphless glyphs, we cannot assume that the face has a well-defined
font, because of the case where font loading during face realization
fails.

I'm not sure why font loading fails in the reporter's specific case, but
it's very likely a system misconfiguration.  One way to induce this bug
is to delete a font file, or change its permissions so that it becomes
unreadable.  When you do this, the fontconfig cache will tell Emacs that
the font exists, but then Emacs fails to load the font when it tries,
triggering this bug.

The reporter should try running `fc-cache -fs' and see if the problem
goes away.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]