bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11822: 24.1; emacsclient terminal mode captures escape characters as


From: Dan Nicolaescu
Subject: bug#11822: 24.1; emacsclient terminal mode captures escape characters as text
Date: Wed, 08 Aug 2012 00:52:28 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

Ken Raeburn <address@hidden> writes:

> On 07/31/12 17:06, I wrote:
>> I still have not seen another occurrence of the original problem I
>> reported, the control-sequence response winding up in the current
>> buffer when I use emacsclient in terminal mode... I'll keep watching
>> for it though.
>
> The problem just occurred again.  I'm running with the fix I posted
> before, so it's not busy logging errors trying to redisplay the header
> line.
>
> I was able to trigger it a second time, with emacsclient -t and no
> filename, and got "1;2403;0c" dumped in my scratch buffer after
> displaying my previously-current buffer in the terminal for a few
> seconds.  Another attempt (emacsclient -t with a filename) got me a
> few seconds of the previously-current buffer and then my file, but no
> extra characters.
>
> I did have a window up on a remote display at the time.  I have since
> closed that window and now the startup delay and wrong-buffer display
> using emacsclient isn't happening.  I suspect they're related; I'll
> see if I can dig into that a little more....

This might be the test for xterm capabilities.
You can try customizing `xterm-extra-capabilities' and see if you still
see the problem.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]