bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11850: bug#11813: bug#11850: crash (null font) running emacs built f


From: Left Right
Subject: bug#11850: bug#11813: bug#11850: crash (null font) running emacs built from git
Date: Thu, 16 Aug 2012 13:51:19 +0300

On Thu, Aug 16, 2012 at 6:25 AM, Chong Yidong <address@hidden> wrote:
> Chong Yidong <address@hidden> writes:
>
>> Nimbus Mono does require Freetype, but if you compile without Xft,
>> Emacs shouldn't be looking for that font at all.  I verified this by
>> doing
>>
>> ./configure --with-xft=no
>> make
>> ./src/emacs -q
>>
>> Then Emacs displays the welcome screen fine
>> Here's something to try: could you try making sure there are no X
>> resources specified, by doing
>>
>> xrdb -remove
>>
>> and running `emacs -Q' to eliminate all customizations?  Does the font
>> problem still show up in that case?
>
> Hi, could you try the steps suggested in this email and let us know the
> results?  Thanks.

Hi, Chong Yidong,
Sorry, since I've reported the issue, I've made a lot of changes to
the system, on unrelated matter. Now I'm using Gnome on Debian
squeeze/sid (a different desktop environment, different kernel etc.).
I've installed Emacs24 from Debian testing, and it doesn't show the
same behavior as before, however, if I compile on my own, - still the
same problem with fonts.

Using the configuration option you suggested, I was prompted for
missing library - tifflib. I've then installed tifflib5-dev from
Debian. The configuration was successful afterwards.
I attach the screenshot of how the version I compiled looks.

Best.

Oleg

Attachment: emacs-bad-fonts.png
Description: PNG image


reply via email to

[Prev in Thread] Current Thread [Next in Thread]