[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#13650: Emacs pretest 24.2.93 - compilation error on AIX 5.3 using gc

From: Paul Eggert
Subject: bug#13650: Emacs pretest 24.2.93 - compilation error on AIX 5.3 using gcc 4.7-2
Date: Tue, 12 Feb 2013 11:03:00 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130110 Thunderbird/17.0.2

On 02/12/13 00:06, Gilles Pion wrote:

> 1st try using default gcc options,

Thanks for following up on this.  Is this a 32-bit build?  Can you
please check that it generated 32-bit object files and that temacs and
bootstrap-emacs are 32-bit?  The command 'file temacs bootstrap-emacs
*.o' might tell you that.

> gmake[2]: *** [autoloads] Illegal instruction

OK, so we've made more progress.  Not only does Emacs (OK, just
temacs) build, it generates bootstrap-emacs (which it didn't do
before).  So I installed that patch into emacs-24 and we can now try
to fix the next problem, namely, that bootstrap-emacs does not execute

Mark Fleishman reported this problem for Emacs 23.3; please see
So I suspect that you'll also observe this problem for Emacs 23.3.
Am i right?  You can grab it from
<ftp://ftp.gnu.org/gnu/emacs/emacs-23.3b.tar.gz> and build it; the
trailing "b" in the version number there should not matter.

At any rate it would be helpful to know which version of Emacs is the
most recent one that worked on AIX.  You can use binary search to find
that out.  The IBM toolbox has Emacs 21.3
so my assumption is that 21.3 will build, but it could be that your
environment differs from IBM's so it might be helpful to check 21.3

> I then have tried to force 64 bit mode

As far as I know 64-bit mode has never worked, though it shouldn't be
hard to get it to work if we can find someone who knows AIX's
executable format.  For now, it may be better focus on getting 32-bit
mode to work, since we know it used to work at some point.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]