bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#13908: Unable to compile Emacs 24.3 stable


From: James Jong
Subject: bug#13908: Unable to compile Emacs 24.3 stable
Date: Thu, 14 Mar 2013 11:45:13 -0400

Thanks Paul. I greatly appreciate your help. I would imagine that building Emacs with a more modern gcc compiler could potentially make Emacs run slightly faster, although the benefits may be marginal if at all noticeable, correct? Feature-wise, I am probably not missing much if anything I guess.

Either way, and just to confirm, I presume that if I  download and build glibc and gcc in a local folder I could eventually compile and run Emacs with a more recent version of gcc/glibc. This would be a long term project for me, but if you have any pointers on how to put something like this together without admin privileges that would be great. 

Other than that, I am all set. Thanks again for your all help,

James


On Wed, Mar 13, 2013 at 6:30 PM, Paul Eggert <address@hidden> wrote:
On 03/13/13 13:15, James Jong wrote:
> I was able to build Emacs 24.3 stable release properly with the system's installation of gcc:
>  ./configure CC=/usr/bin/gcc --without-gif --prefix=/home/avazquez/raid/opt/emacs/releases/emacs-24.3
> make
> make install

Excellent!

> I have now tried to build Emacs with a newer version of gcc such as 4.7.2 with no luck:

Why bother?  You have something that works.

Newer versions of GCC are not compatible with ancient versions of
the GNU C library, particularly if you're trying to use some of
the newer fortification options.  Sorry.  But this is not Emacs's
problem; it's a problem with your build environment.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]