[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#13964: 24.3; randomize_va_space is back

From: Trent W. Buck
Subject: bug#13964: 24.3; randomize_va_space is back
Date: Fri, 15 Mar 2013 21:07:39 +1100
User-agent: Mutt/1.5.21 (2010-09-15)

I ran into this problem:


This fixed it (it was set to 2):

    # echo 0 > /proc/sys/kernel/randomize_va_space

I didn't try setarch -R because I couldn't guess what my arch was to
tell setarch (I tried everything I could think of from "armv7l" to

I'm too lazy to read the whole 2005 thread.  Since etc/PROBLEMS doesn't
mention this issue, only the exec-shield one, I guess this problem was
supposed to be fixed at the time -- so why did I see it today?

In GNU Emacs 24.3.1 (armv7l-unknown-linux-gnueabi)
 of 2013-03-15 on elba
System Description:     Ubuntu 11.10

Configured using:
 `configure '--without-x' '--without-sound' '--without-all'
 '--with-x-toolkit=no' '--with-xpm=no' '--with-gif=no' '--with-jpeg=no'
 '--with-tiff=no' '--with-png=no' '--with-dbus=no' '--with-gsettings=no'
 '--with-gnutls=no' '--prefix=/home/twb/opt/emacs-24.3''

Important settings:
  value of $LC_COLLATE: C
  value of $LANG: en_AU.utf8
  locale-coding-system: utf-8-unix
  default enable-multibyte-characters: t

Major mode: Fundamental

Minor modes in effect:
  ido-everywhere: t
  savehist-mode: t
  icomplete-mode: t
  show-paren-mode: t
  delete-selection-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:

Recent messages:
("emacs" "-f" "report-emacs-bug")
Loading term/xterm...done
For information about GNU Emacs and the GNU system, type C-h C-a.

Load-path shadows:
None found.

(shadow sort gnus-util mail-extr emacsbug message format-spec rfc822 mml
easymenu mml-sec mm-decode mm-bodies mm-encode mail-parse rfc2231
mailabbrev gmm-utils mailheader sendmail regexp-opt rfc2047 rfc2045
ietf-drums mm-util mail-prsvr mail-utils advice help-fns cl-lib
advice-preload jka-compr edmacro kmacro ido savehist icomplete time-date
paren delsel saveplace ediff-hook vc-hooks lisp-float-type
tabulated-list newcomment lisp-mode register page menu-bar rfn-eshadow
timer jit-lock font-lock syntax facemenu font-core frame cham georgian
utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao korean
japanese hebrew greek romanian slovak czech european ethiopic indian
cyrillic chinese case-table epa-hook jka-cmpr-hook help simple abbrev
minibuffer loaddefs button faces cus-face macroexp files text-properties
overlay sha1 md5 base64 format env code-pages mule custom widget
hashtable-print-readable backquote make-network-process multi-tty emacs)

>From IRC debugging:

twb> I'm trying to build emacs from source; there's a point where temacs
twb> deliberately dumps core to make the real "emacs".
twb> I get "Warning: Your system has a gap between BSS and the heap
twb> (15825968 bytes).  This usually means that exec-shield or something
twb> similar is in effect.  The dump may fail because of this.  See the
twb> section about exec-shield in etc/PROBLEMS for more information."
twb> System is an arm Ubuntu 11.10 (tegra2), non-standard kernel and
twb> nonstandard(?) gcc (Ubuntu/Linaro 4.6.1-9ubuntu3), apparmor is not
twb> installed.
twb> etc/PROBLEMS says to check /proc/sys/kernel/exec-shield -- I have no
twb> such file.
twb> What should I check next?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]