bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#15805: 24.3.50; path to lisp/language?


From: Katsumi Yamaoka
Subject: bug#15805: 24.3.50; path to lisp/language?
Date: Tue, 05 Nov 2013 16:29:49 +0900
User-agent: Gnus/5.130008 (真 Gnus v0.8) Emacs/24.3.50 (i686-pc-cygwin)

Eli Zaretskii wrote:
>> Date: Tue, 05 Nov 2013 07:56:59 +0900
>> From: Katsumi Yamaoka <address@hidden>
>>
>> $ emacs -Q
>> Cannot open load file: No such file or directory, japan-util
>>
>> $ export LC_ALL=C; export LANG=C; emacs -Q
>> It runs.
>> And "/usr/local/share/emacs/24.3.50/lisp/language" is found in
>> `load-path'.  But, er, it seems to be missing initially.

> Please step through Fload with a debugger, and see what is going wrong
> there.  Most probably, something is wrong in 'openp'.  I don't have
> access to as system with ja_JP locale to do this myself.

Thanks.
I found what loads japan-util is `normal-top-level'.  In addition,
lisp/subdirs.el hasn't yet been evaluated at that time.  Here's
an xbacktrace:

(gdb) r -Q
Starting program: /Work/emacs-24.3.50/src/emacs -Q
[New Thread 10568.0x2c90]
[New Thread 10568.0x2968]
[New Thread 10568.0x2ec0]
[New Thread 10568.0x2914]
[New Thread 10568.0x37b0]
[New Thread 10568.0x1de8]
[New Thread 10568.0x145c]
[New Thread 10568.0x37d4]

Breakpoint 3, Fload (address@hidden, address@hidden, 
    nomessage=8468530, address@hidden, must_suffix=8468530)
    at lread.c:1044
1044    {
(gdb) xbacktrace
"require" (0x22a558)
"set-language-environment" (0x22a6d8)
"set-locale-environment" (0x22a868)
"normal-top-level" (0x22a9a0)
(gdb) c
Continuing.
[Thread 10568.0x145c exited with code 0]
[New Thread 10568.0x3aa8]
[New Thread 10568.0x4104]
[New Thread 10568.0x4024]
Cannot open load file: No such file or directory, japan-util
[...]





reply via email to

[Prev in Thread] Current Thread [Next in Thread]