bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#15648: 24.2.50; gnutls SSL connection to IMAP server causes emacs to


From: emacs
Subject: bug#15648: 24.2.50; gnutls SSL connection to IMAP server causes emacs to crash completely
Date: Mon, 11 Nov 2013 16:56:41 -0500

Eli Zaretskii wrote at about 22:11:19 +0200 on Monday, November 11, 2013:
 > > From: <address@hidden>
 > > Date: Mon, 11 Nov 2013 14:40:29 -0500
 > > Cc: Alp Aker <address@hidden>, address@hidden,
 > >    address@hidden
 > > 
 > > I tested it against the November 6th build.
 > > 
 > > It seems to work in the sense that now instead of crashing emacs,
 > > gnutls just throws me into the emacs debugger:
 > > 
 > > Debugger entered--Lisp error: (gnutls-error #<process tls> -64)
 > >   signal(gnutls-error (#<process tls> -64))
 > >   gnutls-negotiate(:process #<process tls> :type gnutls-x509pki
 > >   :hostname "imap.gmail.com")
 > >   open-gnutls-stream("tls" "tls-buffer" "imap.gmail.com" "imaps")
 > >   eval-region(19 83 t #[257 "\300\242b\210\301\207" [(83)
 > >   (open-gnutls-stream "tls" "tls-buffer" "imap.gmail.com" "imaps")] 2
 > >   "\n\n(fn IGNORE)"])  ; Reading at buffer position 83
 > >   eval-defun-2()
 > >   eval-defun(nil)
 > >   call-interactively(eval-defun nil nil)
 > >   command-execute(eval-defun)
 > 
 > Thank you.  So I consider this bug resolved, and I'm closing it.

IT IS NOT RESOLVED - all you did was remove the problem from being one
of emacs crashing to the slightly less severe instance of gnutls
itself crashing!

 > > Presumably, this error is due to the fact that
 > > "/usr/ssl/certs/ca-bundle.crt" is not a valid file on Cygwin (despite
 > > the comment in gnutls.el implying that it is!)
 > 

 > No, this is because "/usr/ssl/certs/ca-bundle.crt" _is_ a valid Cygwin
 > file name, but you are not running a Cygwin build of Emacs, where it
 > would be valid.

Why should I be required to only run a Cygwin build of Emacs? Is that
documented anywhere?

 > 
 > > Of course, it all works fine with the elisp patch that I had
 > > previously submitted.
 > 
 > You are free to use that patch, if it suits your needs.  This is Free
 > Software.

And you are free to be obstinate and not admit your mistakes...

 > 
 > > So, now that the bug that crashes the emacs process has been fixed,
 > > perhaps it's time to make gnutls-trustfiles actually work under
 > > cygwin.
 > 
 > They already work under Cygwin.  You probably mean cygwin-mount.el,
 > which is an incomplete and imperfect way of sneaking Cygwin file names
 > into a native Windows build of Emacs and pretending they work.
 > 
 > > So, there remains a fundamental incompatibility between cygwin-mount
 > > and gnutls.el.
 > 
 > Actually, there's a fundamental incompatibility between cygwin-mount
 > and a native build of Emacs.  Just say no.

Cygwin-mount works perfectly for me... it always has...

Plus, the problem is more general than cygwin-mount. The problem
potentially lies with any magic file handler.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]