bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#16998: with-slots should expand to cl-symbol-macrolet


From: Juanma Barranquero
Subject: bug#16998: with-slots should expand to cl-symbol-macrolet
Date: Wed, 12 Mar 2014 17:04:20 +0100

On Wed, Mar 12, 2014 at 4:35 PM, Stefan Monnier
<address@hidden> wrote:

> Current EIEIO still uses `cl' rather than `cl-lib', because it's part of
> CEDET which wants to run on older Emacsen.

My change shouldn't cause problems, because if you require 'cl you
require cl-lib.

But if you want to revert it, we still have a problem that an autoload
for symbol-macrolet or a (require 'cl) is needed.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]