bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#17046: 24.3.50; On startup emacs frame has no minibuffer or windows


From: Juanma Barranquero
Subject: bug#17046: 24.3.50; On startup emacs frame has no minibuffer or windows decorations
Date: Sat, 22 Mar 2014 02:53:19 +0100

On Fri, Mar 21, 2014 at 6:42 PM, martin rudalics <address@hidden> wrote:

> Juanma must likely help now for the HOWTO:

I'm a bit lost here. What do you need from me?

> Can you reproduce the problem with an empty .emacs, just loading the
> desktop file.
>
> And can you try with your usual .emacs but deferring loading the desktop
> file until you have seen your initial frame.

One thing that Robert can try is:

1) Put Emacs in the maximized state, or whatever is that is giving
trouble (just one frame).
2) Exit Emacs (saving the desktop)
3) Copy the "(setq desktop-saved-frameset ...)" line from .emacs.desktop
4) emacs -Q
5) paste the (setq desktop-saved-frameset ...) sexp into *scratch* and eval it
6) eval the following:
   (frameset-restore desktop-saved-frameset
                     :reuse-frames t
                     :cleanup-frames t
                     :force-onscreen t)

Then, repeat from 4) on, with the same desktop-saved-frameset value as
before, but call frameset-restore with :force-onscreen nil (or without
that line, nil is the default).

Assuming that the problem reappears doing that, at least we have a
frameset that causes it, and then we can look into it and try to
understand what happens.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]