[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#16434: bug#16694: bugs #16694/#16378: Patches

From: Eli Zaretskii
Subject: bug#16434: bug#16694: bugs #16694/#16378: Patches
Date: Mon, 28 Apr 2014 22:18:02 +0300

> Date: Mon, 28 Apr 2014 20:36:26 +0200
> From: Matthias Dahl <address@hidden>
> CC: address@hidden, address@hidden, 
>  address@hidden
> On 28/04/14 18:38, Eli Zaretskii wrote:
> > Unfortunately, it doesn't fix the problem.  It looks like the problem
> > is that when make-face-x-resource-internal is called near the end of
> > face-spec-recalc, inhibit-x-resources is already set non-nil, and so
> > make-face-x-resource-internal does nothing.
> Ah, that little bit of information I missed. In that case, everything's
> actually working as intended. If you start Emacs and force it to ignore
> X resources, it does so entirely and as expected... even more so in 24.4
> now. Programmatically "setting" an X resource behind the scenes and
> expecting it to work even though that very system has been asked to do
> nothing, is bound to cause trouble.

I'm terribly sorry, it turns out I tested your change incorrectly.  I
did it correctly this time, and of course the problem is solved.

I committed your changes to the emacs-24 branch.  Thanks.

> I'll have a look at this issue sometime later this week or weekend and
> see what is going on exactly and if there is a way to fix this without
> actually implementing any exceptions into make-face-x-... or anything
> alike.

No need, the problem is solved.  It was my fault.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]