[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#17926: Menu and tooltip glitches using GTK toolkit

From: Robert Parlett
Subject: bug#17926: Menu and tooltip glitches using GTK toolkit
Date: Fri, 04 Jul 2014 12:53:40 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

On 04/07/14 12:07, Jan Djärv wrote:
2014-07-04 00:15, Robert Parlett skrev:
When I click on a menu - say the Options menu, then cursor down to a sub-menu
- say "Line wrapping in this buffer" - then when the pointer reaches the
sub-item, its menu doesn't open. I then have to move the mouse slightly, and
only then does the menu open.

I tried this on Ubuntu 14.04, with emacs 24.4 candidate and emacs trunk. They don't exhibit the problem you describe, sub menus are opened at once.

Further, tooltips in a menu sometimes don't
appear correctly at first. They appear clipped and incomplete, but a further
mouse move makes them redraw correctly.

I can't reproduce this either. In the future, please refrain from reporting two problems in one bug report, make two separate bug reports instead.

Did you starte emacs with -Q? You do not seem to run vanilla Ubuntu, but rather have another theme/window manager. Please give the details of that (i.e. desktop environment, theme, window manager).

No I didn't try emacs with -Q. Now that I try that I see that the problem is somewhat masked by the blinking cursor. Normally, I don't have a blinking cursor - I have (blink-cursor-mode 0) in my init file. When starting with -Q, then the cursor blinks, and the redrawing of the blinking cursor obviously also causes the missing menus and half-drawn tooltips to be redrawn. So with -Q, I just see a short - but still perceivable - delay before the menus/tooltips are drawn correctly. If I then enter (blink-cursor-mode 0) in the scratch buffer, then I see the bug as described originally.

So please try with (blink-cursor-mode 0) and hopefully you will be able to reproduce the bug.

I take your point about filing two separate bugs in one report, but the missing menu and missing tooltip appear (at least so far as I can see) to relate to the same underlying problem, namely a failure to redraw the screen correctly.

Regarding the window manager, it is fvwm. However, I have just tried running emacs in Xephyr, without any window manager at all, and the problem still occurs.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]