bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#17874: 24.3.1; Incorrectly isolated ی in علی


From: Eli Zaretskii
Subject: bug#17874: 24.3.1; Incorrectly isolated ی in علی
Date: Sun, 17 Aug 2014 17:25:27 +0300

> Date: Sun, 17 Aug 2014 11:40:10 +0100
> From: Mat Smiglarski <address@hidden>
> 
> I wonder whether this bug should be reopened?

I'm not sure.  All the signs point towards shaping libraries (libotf
etc.) that are not maintained by the Emacs team, or maybe to specific
fonts.  If that is true, I don't see what we can do with this problem.

Can you try upgrading or downgrading to different versions of libotf
and/or libm17n, or use different fonts?

> The behaviour is also seen when emacs is configured using
> "--without-m17n". Configuring using "--without-libotf" results in all
> glyphs being displayed as isolated.

This is expected.  The INSTALL file says:

  * Complex Text Layout support libraries

  On GNU and Unix systems, Emacs needs the optional libraries "m17n-db",
  "libm17n-flt", "libotf" to correctly display such complex scripts as
  Indic and Khmer, and also for scripts that require Arabic shaping
  support (Arabic and Farsi).

So you cannot have Arabic shaping without those 3 libraries.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]