bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#19373: 24.4; SVG images rendered via librsvg fail at displaying non-


From: YAMAMOTO Mitsuharu
Subject: bug#19373: 24.4; SVG images rendered via librsvg fail at displaying non-inline bitmap images
Date: Thu, 18 Dec 2014 12:50:33 +0900
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.6 Emacs/22.3 (sparc-sun-solaris2.8) MULE/5.0 (SAKAKI)

>>>>> On Wed, 17 Dec 2014 21:00:54 +0100, Ulf Jasper <ulf.jasper@web.de> said:

> This is related to rsvg bug 596114 "image refs are relative to
> curdir, not .svg file" [2].  I just pushed a fix to master (c17c864)
> which should fix this.

I suspect it is not appropriate to refer to buffer-local variables of
the current buffer inside image loading functions:

diff --git a/src/image.c b/src/image.c
index 1a2c0e2..0bebd45 100644

[snip]

@@ -8818,7 +8822,9 @@ svg_load (struct frame *f, struct image *img)
          image_error ("Invalid image data `%s'", data, Qnil);
          return 0;
        }
-      success_p = svg_load_image (f, img, SDATA (data), SBYTES (data));
+      original_filename = BVAR (current_buffer, filename);
+      success_p = svg_load_image (f, img, SDATA (data), SBYTES (data),
+                                  SDATA(original_filename));
     }
 
   return success_p;

Maybe SVG image descriptors should accept the property `:base-uri' or
something?

                                     YAMAMOTO Mitsuharu
                                mituharu@math.s.chiba-u.ac.jp





reply via email to

[Prev in Thread] Current Thread [Next in Thread]