bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#19993: 25.0.50; Unicode fonts defective on Windows


From: Eli Zaretskii
Subject: bug#19993: 25.0.50; Unicode fonts defective on Windows
Date: Wed, 11 Mar 2015 06:28:54 +0200

> Date: Tue, 10 Mar 2015 13:32:24 -0700
> From: Ilya Zakharevich <address@hidden>
> Cc: address@hidden
> 
>    • on your system
>    • with Symbola installed
>    • with the default configuration
> I presume that Math Alphabeticals are not shown (but ARE shown when
> Symbola is EXPLICITLY marked as the default font for them).

If you mean the Mathematical Alphanumeric Symbols block, then they are
indeed not shown, although I have quite a few fonts that support that
range, not just Symbola.

>              WHY?

I don't know.

> With my conjectures, the explanation would be that a certain other
> font on the system has the Math Alphabeticals Subset “identified”, so
> this font is chosen by Emacs — but in reality, this font does not
> support the whole subset, so the needed glyphs are missing.  (For
> example, DejaVu has Monospaced range, and nothing else. [Well, the
> glyphs in the Monospaced range are totally broken, but that is
> irrelevant for the current discussion!])

Did you try to uninstall DejaVu (and any other font that claims
support for this range, but doesn't really cover these characters),
and see what happens then?  If the problem persists, then this is not
the real reason.

> Without my conjecture, what would be your explanation?

I don't have one.  I could hypothesize, say, that Emacs simply lacks
some wisdom to find a font for that range, but I think you will be
much better off studying the relevant code and walking through it with
a debugger, than by asking me for explanations in these matters, about
which I know very little.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]