bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20549: 24.5; tcl.el: sending region to tcl process produces error


From: Alain Kalker
Subject: bug#20549: 24.5; tcl.el: sending region to tcl process produces error
Date: Tue, 12 May 2015 19:15:11 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.6.0



On 05/12/2015 08:39 AM, Glenn Morris wrote:
address@hidden wrote:

- Visit a Tcl boffer
- Start a new Tcl process using C-c C-t
- Select a region containing one or more Tcl commands
- Try and send it to the Tcl process using C-c C-x

Actual results:
- Emacs reports an error: "error in process filter: Text is read-only"

Thanks for the report, but I can't reproduce this.
Can you give a complete example starting from emacs -Q?

Ah, I'm sorry, i realize i did forget to mention a crucial piece of the puzzle (marked with + below), namely that I have customized a variable to have read-only prompts in comint buffers.
Here is the corrected list of steps:

- Start Emacs as `emacs -Q`
+ Configure prompts to be read-only using M-x set-variable RET comint-prompt-read-only RET t
- Visit a new Tcl file, example test.tcl
- Enter a Tcl command for testing, say `puts 42`
- Start Tcl process using C-c C-t
- Switch back to test.tcl buffer using C-x o
- Select all text using C-x h
- Try and send it to Tcl process using C-c C-x

This produces the error which I mentioned earlier.

Kind regards,

Alain





reply via email to

[Prev in Thread] Current Thread [Next in Thread]