bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20624: 25.0.50; cannot install packages due to remove-dups symbol de


From: Gregor Zattler
Subject: bug#20624: 25.0.50; cannot install packages due to remove-dups symbol definition void
Date: Thu, 21 May 2015 21:16:03 +0200
User-agent: Mutt/1.5.23 (2014-03-12)

With GNU Emacs 25.0.50.2 (i686-pc-linux-gnu, GTK+ Version 3.14.5) of 2015-05-21 
on boo

build with latest commit being
96794d2f97cd064e4c2bf4f71459b42558cc8c79

I cannot install any package due to error
„Symbol’s function definition is void: remove-dups“

Whole *Message* buffer contents:

Importing package-keyring.gpg…done
Setting ‘package-selected-packages’ temporarily since „Emacs -q“ would 
overwrite customizations
Package refresh done
Install package ‘adaptive-wrap-0.5’? (y or n) y
Package menu: Operation started [Installing 1]
package-menu-execute: Symbol’s function definition is void: remove-dups


I git bisected this:

a31ca4ef50efae51f9281be11cb6668789a57f08 is the first bad commit
commit a31ca4ef50efae51f9281be11cb6668789a57f08
Author: Artur Malabarba <address@hidden>
Date:   Thu May 21 17:10:40 2015 +0100

* lisp/emacs-lisp/package.el: Fix selected-package logic

(package-menu-execute): Mark as selected all non-upgrade packages
being installed.
(package-menu--perform-transaction): Don't mark anything.

:040000 040000 17f710f413deca503ec5670fd73bcb40d2ad4b75 
14f8971e10190cc5bf4ddb1779899823133dafd4 M      lisp


HTH, Gregor






reply via email to

[Prev in Thread] Current Thread [Next in Thread]