bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20623: XML and HTML files with encoding/charset="utf-8" declaration


From: Simon Ledergerber
Subject: bug#20623: XML and HTML files with encoding/charset="utf-8" declaration loose BOM; Coding system is reset from utf-8-with-signature to utf-8 on save
Date: Sat, 23 May 2015 19:11:15 +0200

As already mentioned in my last post, even when I started Emacs with the option -Q, which should opt out my customizations, it made no difference. So naturally, the source of the problem will be somewhere else.

From: Eli Zaretskii
Sent: ‎23.‎05.‎2015 08:44
To: Stefan Monnier
Cc: address@hidden; address@hidden
Subject: Re: bug#20623: XML and HTML files with encoding/charset="utf-8" declaration loose BOM; Coding system is reset from utf-8-with-signature to utf-8 on save

> From: Stefan Monnier <address@hidden>
> Cc: address@hidden,  address@hidden
> Date: Fri, 22 May 2015 17:51:07 -0400
>
> >> > What would you expect Emacs to do instead?  It just obeys the stated
> >> > encoding, which says nothing about the BOM.  How can Emacs know when
> >> > to use utf-8 and when utf-8-with-signature?
> >> To the extent that Emacs has seen the BOM when opening the file, it
> >> would make sense for Emacs to try and preserve this detail.
> > It does.
>
> While there are cases where it does, this bug report is about a case
> where it doesn't, IIUC.

AFAIU, that happened because the user has this in ~/.emacs:

  (setq-default buffer-file-coding-system 'utf-8-dos)

IMO, this bad customization should be removed, and then the problem
will go away.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]