bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20681: Build failure [MSYS2/MINGW64, OSX]


From: Angelo Graziosi
Subject: bug#20681: Build failure [MSYS2/MINGW64, OSX]
Date: Fri, 29 May 2015 14:27:07 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.7.0



Il 28/05/2015 19:47, Eli Zaretskii ha scritto:
Date: Thu, 28 May 2015 14:55:50 +0200
From: Angelo Graziosi <address@hidden>

The build I tried with current master failed. This occurs in the
nextstep build on OSX and also in the MSYS2/MINGW64 on Windows. The same
master builds fine in the GTK build on GNU/Linux (but here there are
other issues; see bug #20677).

The failure looks the same.

On OSX:

[...]
    GEN      dirent.h
    GEN      fcntl.h
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-am
    CC       acl-errno-valid.o
    CC       acl-internal.o
    CC       get-permissions.o
    CC       set-permissions.o
set-permissions.c:569:20: warning: incompatible pointer to integer
conversion passing 'acl_t' (aka 'struct _acl *') to parameter of type
'int' [-Wint-conversion]
            acl = acl_init (acl);
                            ^~~
/usr/include/sys/acl.h:149:27: note: passing argument to parameter
'count' here
extern acl_t    acl_init(int count);
                               ^
set-permissions.c:585:26: error: use of undeclared identifier 'acl'
          ret = acl_set_fd (desc, acl);
                                  ^
set-permissions.c:587:47: error: use of undeclared identifier 'acl'
          ret = acl_set_file (name, ACL_TYPE_EXTENDED, acl);
                                                       ^
set-permissions.c:590:27: error: use of undeclared identifier 'saved_errno'
            if (! acl_errno_valid (saved_errno) && !
acl_extended_nontrivial (acl))
                                   ^
set-permissions.c:590:70: error: use of undeclared identifier 'acl'
            if (! acl_errno_valid (saved_errno) && !
acl_extended_nontrivial (acl))

       ^
1 warning and 4 errors generated.
make[2]: *** [set-permissions.o] Error 1

Should be fixed now.  (set-permissions.c cannot be compiled on MinGW,
and is unnecessary there, so I removed it from the build.)

This bug has been closed... but..

P.S. Thanks to Paul who made this fix easy by merging the gnulib
changes in nt/gnulib.mk.

current master still fails to build on OSX. Same error..


Ciao,
 Angelo.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]