bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20834: 25.0.50; install-autoremove cycle with the tablist package


From: Tassilo Horn
Subject: bug#20834: 25.0.50; install-autoremove cycle with the tablist package
Date: Fri, 19 Jun 2015 07:59:11 +0200
User-agent: Gnus/5.130014 (Ma Gnus v0.14) Emacs/25.0.50 (gnu/linux)

Andreas Politz <address@hidden> writes:

>> [...]  In its git repository, it has tablist.el bundled but that's
>> not distributed via the package.  Reported here:
>>
>>   https://github.com/politza/pdf-tools/issues/103
>>
>> Does that explain something?
>
> No, this is only relevant if you're using cask.  From melpa's POV
> pdf-tools and tablist are different packages and the dependency of the
> former on the later is stated in pdf-tools.el .
>
> But for a period of time (and unknown reasons), melpa hosted a broken
> pdf-tools package, which had no dependencies and no description.
> Sounds like this was causing your problems.

Yes.  Since the cycle doesn't appear anymore, I guess it was due to the
other (now fixed) package.el bug which didn't properly delete old
versions (bug#20836).  I guess, some older pdf-tools version had the
tablist dependency, and then when upgrading to the newer version with
missing deps, tablist became auto-removable.  But when starting again,
package.el also found the older version which still depended on tablist,
so it had to be installed again.

Well, I didn't actually verify that but it seems like a plausible story.
So I'm closing this issue and file a new one if it ever reappears.

Bye,
Tassilo





reply via email to

[Prev in Thread] Current Thread [Next in Thread]