bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22054: Potential errors in package--builtins


From: Artur Malabarba
Subject: bug#22054: Potential errors in package--builtins
Date: Tue, 1 Dec 2015 11:24:03 +0000

2015-11-29 19:24 GMT+00:00 Jonas Bernoulli <address@hidden>:
> * `ielm' is missing from the list.  I suspect it is not detected as a
>   package because the first line does not contain the summary.

No. It needs a version number to be considered a package. But then,
why should it be on the list? Is it also provided in one of the
archives?

> Also, shouldn't the "interaction mode for Emacs Lisp" be located inside
>   lisp/emacs-lisp/?

Last I was told, lisp/emacs-lisp is for libraries to be used by other
elisp code. But then, not all files in there perfectly fit that
description either.
So I'll let someone who cares about that continue this line of thought. =P

> * `cl-preload' is listed as a separate package.
>
> * `eieio-compat' is listed as a separate package.  But I suspect that
>   is intentional.  Not sure though.
>
> * `sasl-scram-rfc' is listed as a separate package, but all the other
>   `sasl-*' libraries are part of the `sasl' package.

Assuming you mean cl-preloadED.el... Maybe someone just fixed it but
none of these are listed as built-ins for me.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]