bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22392: Emacs OS X GUI doesn't set locale


From: Alan Third
Subject: bug#22392: Emacs OS X GUI doesn't set locale
Date: Tue, 26 Jan 2016 22:50:40 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (darwin)

Anders Lindgren <address@hidden> writes:

> Hi,
>
> This sounds like a good change. Unfortunately, I can't answer the
> locale-questions you raised in the mail. However, I have a few small
> questions:
>
> * Why a separate source file? Is there any technical reasons why this
> couldn't reside in, say, nsterm.m?

No, I just wasn't sure what the deal was with including files like that
in emacs.c since there's quite a lot in it. If that's an acceptable way
to do it then I'd be happy to do so.

> * Can you add a "NSTRACE" line to the function, so that it's clear
> when this function is called, when NSTRACE is enabled.

I don't know what that means, but I'll look into it.

> * Have you considered populating `process-environment' instead of
> setting LANG in the Emacs process? Would there be any
> advantages/disadvantages with this approach?

The problem is that Emacs itself doesn't know what the correct locale is
and therefore sets various encodings and things to "nil". As far as I
can tell process-environment is only for sub-processes, which doesn't
solve this particular problem.
-- 
Alan Third





reply via email to

[Prev in Thread] Current Thread [Next in Thread]